EC2で古いPHPをアンインストールし、PHP5.4をインストールする

AmazonLinux ではphp5.4とApache2.4は紐付けられている(普通そうなのかな?)。そのため、php5.4を使いたい場合には、同時にApache2.4もインストールする必要がある。

以上の理由から、インストールの前準備として、古いバージョンのphpApacheの両方をアンインストールする。
アンインストール後、php5.4とApache2.4の両方をインストールしましょう。


参考
http://d.hatena.ne.jp/paraches/20110708/1310096175

yum remove php-* httpd-*

参考
http://aws.amazon.com/jp/amazon-linux-ami/2012.09-release-notes/

yum install httpd24 php54